What is a little tweak or change we can make to Maya?

A fix for the Camera dolly (alt+RMB) slow down

Occasionally when you try and dolly (often incorrectly called zooming) into an object using Alt+RMB in the viewport, the dolly movement slows down the closer you get to said object. Frustrating, because often you can't get close enough. The work around is to reframe the viewport and try again. This problem has been around in Maya for longer than I can remember. It would be so nice to finally get this fixed.

46 votes
Vote
Sign in
Signed in as (Sign out)
You have left! (?) (thinking…)
DutchDimensionDutchDimension shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

4 comments

Sign in
Signed in as (Sign out)
Submitting...
  • gilleybabagilleybaba commented  ·   ·  Flag as inappropriate

    ChAoS_0 the Dolly Tool options doesn't fix this issue. This issue only happens in the orthographic viewports(Front, Side, Top) and doesn't happen with the Persp view. This issue has been in Maya since for as long as I've been using it(10+ years) and it's very annoying.

    Simplest way to see this issue is to create a box then focus on it in an ortho viewport.
    Now using the scroll wheel on your mouse, zoom in on the box 1-click
    Now zoom out 1-click using the scroll wheel.

    Notice how you just zoomed out at least 2x as much as you zoomed in. This also happens with the alt+RMB zooming. You see an "acceleration" and "decceleration" when zooming in/out in the ortho viewports.

  • Malcolm AndrieshynMalcolm Andrieshyn commented  ·   ·  Flag as inappropriate

    My work around for this issue is to dolly all the way in as normal, then use the mouse wheel it will get you past the slow point and alt+rmb will be speedy again.

  • ChAoS_OChAoS_O commented  ·   ·  Flag as inappropriate

    There are already options for this - take a look at the Tool Settings for the Dolly Tool

Feedback and Knowledge Base