What is a little tweak or change we can make to Maya?

Maya 2017: Can't type in decimal numbers in Attribute Editor

We have three guys at our studio that have all started using Maya 2017 and none of us can enter decimal numbers in the Attribute Editor.
I've deleted the Maya preference file, but it did not help.
Please fix it.

53 votes
Sign in
Signed in as (Sign out)
You have left! (?) (thinking…)
tarjeptarjep shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in
Signed in as (Sign out)
  • NaomiNaomi commented  ·   ·  Flag as inappropriate

    I have just installed Maya LT and had the same issue. (I know Maya users still have the issue as it is appearing in the forum https://forums.autodesk.com/t5/maya-forum/maya-2017-problem-when-i-manually-input-values-they-get-reset/td-p/6465588/page/2 ).
    I have a Swiss keyboard and I couldn't enter decimal numbers in the editor; when I tried to type a dot, it wasn't appearing, and when I tried to type a comma (default decimal separator for Swiss keyboard), the value got reset.

    I solved it by using ovhima's solution in the Windows Language Settings and changing the decimal separator from a comma to a dot, then restarted Maya LT.

    But I shouldn't have to do that !!

    There's no acceptable reason why I can't type a dot in the first place... I can type decimals fine in any other software.

  • tarjeptarjep commented  ·   ·  Flag as inappropriate

    Seems like it's fixed in the latest update (update2). Just took them about 4 months to fix.

    I also came over this on the release notes site.

    "Maya 2017 marks a shift in the way Maya is maintained and updated to provide quicker access to new features, and quicker fixes to customer issues."

    Yeah right....

  • tarjeptarjep commented  ·   ·  Flag as inappropriate

    That Autodesk still hasn't dealt with this bug or even responded to this thread is proof that the developers really don't care about the users. Which in turn is the reason why I think a lot of Maya users feel extremely frustrated. It's been almost three months since I posted about this bug and still nothing. No point in having this website if the devs jump in once every few months. Autodesk, you should learn from your newly acquired SolidAngle team. That is a team that cares about their customers!

  • pixeldust2pixeldust2 commented  ·   ·  Flag as inappropriate

    Very annoying indeed. Thought that a bug this obvious would long be fixed with update 1 but it wasn't.

  • Roland ReyerRoland Reyer commented  ·   ·  Flag as inappropriate

    I'm using a german Windows 10, german keyboard and for Maya I'd switch the keyboard to US layout (many hotkeys won't work with the german keyboard).
    In Maya 2016 I could enter decimal numbers in any format with period or comma, with or without leading digit.
    In Maya 2017 I can TYPE a comma (,25) but it results in 0.000
    I can NOT type a period as a first character - the field simply doesn't react.
    Only when I type the format "digit(s) period digit(s)" like "0.25" then it works.
    That workaround is ok for me, but I'd like the old behaviour back.

  • pascalcpascalc commented  ·   ·  Flag as inappropriate

    Same problem on OS X in France. (And a lot of others)
    I setup a keyboard since few years to have the dot in the numeric pad, and that worked fine till now...
    Impossible to use maya 2017 !

  • hellobardhellobard commented  ·   ·  Flag as inappropriate

    Same problem here. Fixed it by ovihma's suggestion in the Control Panel
    (Windows 8.1 Norwegian)

  • ovihmaovihma commented  ·   ·  Flag as inappropriate

    Try Control Panel -> Region and Language -> Additional Settings -> Decimal symbol -> .

  • hellsingshellsings commented  ·   ·  Flag as inappropriate

    I have fix this probleme by changing the region format to english USA in the configuration on windows 10

  • tarjeptarjep commented  ·   ·  Flag as inappropriate

    Hi hellsings, nope we haven't figured this out yet. But some other guys at the studio tested with the Linux version and that had no issues. I think it is related to language and OS somehow...

  • hellsingshellsings commented  ·   ·  Flag as inappropriate

    Same probleme here on three different instale. but it is not only for the attribute editor it's nearly everywhere. Did you figure this out??

Feedback and Knowledge Base